Vous êtes ici Forums
  |  Connexion
 Forums
HomeHomeForums DNNForums DNNDéveloppementDéveloppementModule: Problème avec vueModule: Problème avec vue
Précédente
 
Suivante
Nouveau message
17/11/2014 13:12
 

Bonjour à tous,

J'ai développé un module pour un client.

Qui gérer des formations, par thèmes et dates.

Une vue liste avec zone de filtre.

Une vue qui affiche la formation sélectionner.

La possibilité de Créer, Modifier, Supprimer des Thèmes.


Tout fonctionne correctement à une exception prés.

Ma vue qui affiche la formation "ShowItem" fait appel au fichier "DesktopModules/MonModule/ShowItem.ascx", sauf que j'ai un petit problèmes le client m'a demand& de rajouter un lien sur un fichier PDF dans la vue, donc j'ai modifié le  fichier ShowItem.ascx en rajoutant '<a href="/monpdf.pdf">monpdf</a>' rien de sorcier.

Mais quelque chose de magique ce passe, ça ne change pas l'affichage, chose d'autant plus folle, lorsque je supprime mon fichier ShowItem.ascx, ma page sur le site fonctionne toujours.

Je n'ai aucun autre fichier ShowItem.ascx dans les répertoires Portals ou autres.

Et Lorsque en base je modifie l'entrée de ma vue dans la table [ModuleControls] ça ne change rien la vue fonctionne toujours.

J'ai redémarrer mon pool, redémarrer mon site, redémarrer le site via l'admin, mis à jour la DLL, supprimer tout les dossiers "cache" se trouvant dans le site, rien que j'ai pu faire ne modifier ma vue.


Quelqu'un aurais t'il déjà eu un problème similaire ou un idée pour m'aider, car là je suis vraiment bloquer, je ne sais plus quoi faire (mis à part supprimer et réinstaller le module, mais ça me ferais perdre mes données lié au module et ce n'est pas envisageable)

 
Nouveau message
17/11/2014 15:21
 

C'était simplement que j'appelais pas la bonne page sur l'action du bouton.

 
Précédente
 
Suivante
HomeHomeForums DNNForums DNNDéveloppementDéveloppementModule: Problème avec vueModule: Problème avec vue