Vous êtes ici Forums
  |  Connexion
 Forums
HomeHomeForums DNNForums DNNDesign, présent...Design, présent...pb css dnn4pb css dnn4
Précédente
 
Suivante
Nouveau message
30/11/2012 12:24
 
pb css dnn4  (N/A)

Bonjour ,

J'utilise un placeholder de dotnetnuke 4.05 pour faire un menu mais je rencontre un problème de css avec firefox 17, pour les autres navigateurs pas de problème.

voici le résultat :

mon skin utilise le doctype suivant : <!DOCTYPE HTML PUBLIC ""-//W3C//DTD HTML 4.01 Transitional//EN"">

et voici le menu sous d'autre navigateur :

Pouvez-vous m'aider ?

merci d'avance


Cordialement


 
Nouveau message
30/11/2012 13:04
 
Re: pb css dnn4  (N/A)

Bonjour,

Ce problème est dù à un changement dans le User Agent String de Firefox 17, plusieurs autres projets sont impactés (Moodle, FckEditor, ...) et pas seulement DNN ! Résultat FF n'est plus 'identifié' comme étant FF mais un comme un navigateur 'inconnu' et dont les possibilités sont indéfinies.

J'ai bien essayé de trouver une solution dans le forum US en modifiant certains fichiers utilisés par ASP.NET pour détecter correctement FF17, mais cela ne résoud pas le problème car certains modules et/ou providers (dont le système de menu des versions 4.x) font aussi 'leur' test de navigateur en interne. Donc FF17 est bien détecté par le système mais pas par certains composants !

Ce problème à été remonté par plusieurs utilisateurs de différents projets dans les forums Mozilla. Je ne sais pas s'ils vont faire 'machine arrière' sur cette modification du User Agent String. Tu as donc trois solutions :

- Utiliser un autre navigateur. Demie solution car tes visiteurs utilisant FF17 auront le même problème !

- Attendre que FF corrige ce problème.

- Mettre à jour ton instance DNN vers la version 6.2.5 voire la toute dernière 07.00.00 (sortie il y a quelques jours, mais à ta place j'attendrais un peu avant de l'utiliser) et utiliser le nouveau système de menu 'DDR Menu' dans ton web.config. Il faut savoir que les versions 4.x ne sont plus supportés depuis longtemps, idem pour les versions 5.x !

Gilles

 
Nouveau message
30/11/2012 14:00
 
Re: pb css dnn4  (N/A)

Pour info le fichier à actualiser par une version plus récente est :

js\ClientAPICaps.config

 

 
Nouveau message
30/11/2012 14:25
 
Re: pb css dnn4  (N/A)

merci pour les informations.

c'est vrai qu'on ne peux plus clicker sur le management element avec ff17.

j'ai mis à jour le fichier ClientAPICaps.config mais j'ai une erreur : Requested+value+'Motion'+was+not+found

je vais faire un morceau de jquery avec le navigator.userAgent et forcer le css.






 
Précédente
 
Suivante
HomeHomeForums DNNForums DNNDesign, présent...Design, présent...pb css dnn4pb css dnn4